Back to overview
Resolved

Delayed event processing and elevated API error rates

Jul 24, 2026 at 11:00pm UTC
Affected services
REST API
Dashboard
General Messages

Resolved
Jul 24, 2026 at 11:00pm UTC

Between approximately 12:57 and 13:52 (GMT+3) our platform experienced delays in processing incoming events and an elevated rate of API call failures.

During this window, events that were successfully sent to Solitics were received and retained, but processed with a delay of up to ~50 minutes at peak — as a result, triggered promotions, journeys, and real-time messages may have been sent later than expected.

No data was lost , all received events were queued and have since been fully processed. Processing has returned to normal and we are monitoring closely.

We apologize for the inconvenience.