Back to overview
Downtime
Dashboard Performance Degradation
Feb 11 at 10:52am UTC
Affected services
REST API
Dashboard
Resolved
Feb 11 at 11:35am UTC
The dashboard performance issue has been fully resolved.
Thank you for your patience and understanding.
Affected services
Created
Feb 11 at 10:52am UTC
We are currently experiencing an issue that is causing slowness in the dashboard.
The issue began on February 11, 2026 at 12:53 PM IST.
Our engineering team is actively investigating and working to resolve it as quickly as possible.
We will provide an update as soon as the issue is resolved.
Thank you for your patience and understanding.
Affected services